Blog > IC-Switch 1.5b1

 IC-Switch 1.5b1

  
IC-Switch 1.5b1

By popular request and after years and years of faithful services, IC-Switch 1.4 is now going 1.5.

The only change, though, is that it's now built for Intel processors running on 10.6.x or newer only, which makes it compatible with the upcoming Lion.

Details and download of the 1.5b1 here.

 Previous Comments

There are no comments yet. Be the first to post one!

Please Log in if you wish to comment.